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1.0 INTRODUCTION 

1.1 Background 
Land cover refers to the composition and characteristics of land surface elements, 

representing key environmental information. It is an important determinant of land use and 

hence of great importance to the society. Land cover varies at a range of spatial scales from 

local to global, and at temporal frequencies of days to millennia. As the need for 

environmental planning and management became important, an accompanying call for land 

cover information emerged in parallel. Land cover mapping is one of the common and 

applicable uses of remote sensing data. Specifically it is applied in natural resource 

management, urban planning, hydrological modeling and exploration of oil, gas, and 

minerals. The access to the previous data makes it possible to detect land cover back in time, 

and the subsequent continued supply of new images data allows for effective detection of 

changes in land cover in a certain time period. The process of performing a land cover 

classification based on a satellite image is basically a system of simplifying the wealth of 

information present in a satellite image into information that is easy to interpret for the end 

users (Chennai, et. al 2015; Cihlar, 2000; Malik & Husain, 2006). 

The complexity of a specific classification procedure depends on many factors including the 

size and area of investigation, the required number of classes, the projected accuracy and in 

most cases the quality of the available satellite imagery data. The basic principle behind 

most land cover mapping is the ability to distinguish different surface covers based on their 

spectral signatures (i.e. a unique combination of reflected electro-magnetic radiation in 

different spectral bands). Occasionally this has been performed using pixel based image 

analysis, whereby each pixel’s digital number is assessed individually. Besides, an object-

based image analysis, whereby pixels are aggregated in a first step (segmentation) into 

objects that are homogeneous with regard to spatial or spectra characteristics. After which 

spectral, textural, shape or textual criteria can then be applied to interactively classify the 

objects into a predefined set of classes (Malik & Husain, 2006). 

1.2 The Training Objectives 
The objective of this training is to provide remote sensing image processing and Geographic 

Information Systems (GIS)  skills to researchers and coastal resource managers, to enble 

them to identify coastal vegetation (mangroves and seagrass/sub-merged vegatation) cover 

types along Kenya, Tanzania, Mozambique and Madagascar coastlines. Because satellites 

beam back information every day, satellite imagery can be an excellent source of very 
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current or historic information. Specifically, this training module uses Landsat 7 ETM+ 

(Enhanced Thematic Mapper Plus) and Landasat 8 OLI (Operational Land Imager) 

imageries from 2010 to 2014. You will be guided through the necessary steps for acquiring, 

processing, classifying, interpreting and examining different classes in the study areas. 

Initially, you will analyze Landsat images to identify various natural and human-developed 

features present on the surface into land cover classes. These classifications will then be used 

to detect areas where mangrove forests occur within the project areas. 

2.0 FILE MANAGEMENT 

2.1 Data Files Directory and Data Formats 
The satellite Images (raster data) used in this training manual are in GeoTIFF format, and 

the GIS data are in Shapefile format. File management is crucial for a successful project! 

Before you start compiling your data, ensure that you have become familiar with the file 

structure and the data used in this training project. If it has not been set up for you, you can 

create the folders on the drive on which you are allowed to save data. Open Windows 

Explorer and create the folder structure below on your working drive. In this case, they have 

been created on the “D” drive. The project is named "TRAINING DATA_LANDSAT8" 

with the following subfolders: accuracy_test, Imagery, shapefiles and output.  

 NB: Make sure the "TRAINING DATA_LANDSAT8" is copied to your computer  

preferably on the ''D'' compartment. 

3.0 SATELLITE DATA ACQUISITION AND PRE-PROCESSING 

3.1 Satellite Data Acquisition and Pre-processing: Landsat Imagery 

 

Figure 1: Illustration of of Lansat 8 Observatory. Source:(“LANDSAT 8 (L8) DATA USERS 

HANDBOOK Version 1.0 June 2015,” 2015). 



3 
 

Landsat program has provided over 42 years of calibrated high spatial resolution data of 

Earths's surface for various uses by the world community, cutting across differing fields: 

agribusiness, climate change science, decision makers just to mention a few. The main 

mission of the Landsat is to make available repetitive acquisition of moderate-resolution 

multispectral data of the Earth's surface (“LANDSAT 8 (L8) DATA USERS HANDBOOK 

Version 1.0 June 2015,” 2015). 

3.1.1 Landsat Missions 

 

MSS(Multispectral Scanner),OLI(Operational Land Imager),TIRS(Thermal Infrared Sensor), 

TM(Thermatic Mapper), ETM+(Enhanced Thermatic Mapper Plus), RBV (A return Beam Vidicon) 

 

Figure 2: Continuity of multispectral data coverage provided by Landsat missions beginning 

with Landsat 1 in 1972: Source (“LANDSAT 8 (L8) DATA USERS HANDBOOK Version 1.0 

June 2015,” 2015). 

3.1.2 Lansat 8 & 7: What's different or new? 

The Landsat 8 observatory offers many capabilities over its predecessor, Landsat 7. 

 

Figure 3: Comparison of Landsat 7 and Landsat 8 Observatory Capabilities 



4 
 

 

Figure 4: OLI and TIRS Spectral Bands Compared to EMT+Spectral Bands 

OLI has two new bands besides the original Landsat bands (1-5, 7, and Pan). The 

Coastal/Aerosol band (band 1; 0.435-0.451micrometres) and the new Cirrus band (band 9; 

1.36-1.38 micrometres) aids in detection of thin clouds comprised of ice crystals (cirrus 

clouds will appear bright while most land surfaces will appear dark through an otherwise 

cloud-free atmospheres containing water vapour) 

 

Figure 5: Landsat 8 Spectral Bands and Wavelengths compared to Landsat 7 EMT+ 

3.1.3 Landsat Data Availability and Download 

All products are accessible via the internet for download via HTTP; there are no product 

media options. Landsat data are available at no cost to the user. Available data can be 

viewed through a number of interfaces: 

 Earth Explorer:http://earthexplorere.usgs.gov 
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 Global Visualization Viewer:http://glovis.usgs.gov 

 LandsatLook Viewer:http//landsatlook.usgs.gov 

3.1.4 A look at Global Visualization Viewer (GloVis) 

The Global Visualization (GloVis) Viewer is an easy to operate browse-based tool which 

displays all available Landsat scenes achieved in the USGS database. See the link above.  

NB:The latest version of Java needs to be installed on your computer. 

3.1.5 Exercise 1: Getting Started with Global Visualization Viewer (GloVis) 

Interface 

 

Figure 6: Global Visualization Viewer (GloVis) Interface 

When first opened, the viewer displays the most recent, least  cloudy image of Path 28  Row 

31 (Southeast South Dakota) Figure 6. One can navigate to an area of interest by feeding a 

Path/Raw, Latitude/Longitude decimal coordinates, or moving the map using the mouse. 

Though, regardless of where the map is moved, the most recent, least cloud free image will 

be displayed. Users can then "page"  through all of the scenes covering the same Path/Row 

area, using the arrows or Previous Sceneand Next Scene buttons on the left side. Cloud 

limits can also be changed on the left side of the viewing window. 

The collection  menu lists the searchable data sets, including Landsat 8. The Resolution 

Menu allows the display to be changed from 1000 meters ( 9 scenes in the view) to 250 

meters only (only the selected scene will be displayed). Map layers (cities, 
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country/administration boundaries, roads) can be added to aide in the search. The Tools 

Menu allows users to set search limits or look for specific scene ID's. Users can also compile 

and save scene lists from the tool, or upload already created scene lists. Scenes added to the 

Scene List are sent to the Cart, which forwards the request to EarthExplorer and prompts 

users to login. The data can then be downloaded individually, or added to bulk download 

order. 

 

Figure 7: Path/Row 166/62 within the entire Kenyan Coastline 

3.2 Landsat Data Pre-processing: Quick Atmospheric Correction (QUAC) in 

ENVI 5.1 
The following example describes how to use QUAC with Landsat imagery. Because Landsat 

scenes typically have large areas of background pixels, the example shows how to apply a 

mask that excludes these areas from QUAC processing. 

3.2.1 Exercise 2: Starting the software ENVI 5.1 
Envi can be started using desktop shortcut icons or through program files and Envi 5.1 

folder where Envi+IDL or Envi stand alone can be started by a single mouse click as shown 

below 
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Figure 8:Lauching  Envi 4.7 through program files Menu 

Exercise 3: Opening and loading the Image: Click the Open button  in the toolbar. 

 

Figure 9: Loading the Image 

Go to G:\TRAINING DATA_LANDSAT8\Imagery and load LC81660632014036LGN00 

 

1. For Landsat 8, select a *_MTL.txt metadata file.  

2. For Landsat 4, 5, or 7 images with metadata, select a*_MTL.txt, *_wo.txt, or *.met file. By 

opening the metadata file, ENVI reads the entire dataset plus the available metadata. 

3. Right-click on the Landsat filename in the Data manager and load True Color.  

4. Then right click Layer Manager and select Zoom to Layer Extent. Now you can see the 

black background pixels, for example: 
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Figure 10: Loaded Image showing black background pixels 

5. Click the Cursor Value button  in the toolbar, and then move the cursor over the 

background pixels to verify their values. The pixel values are 0, 0, and 0 for the R, G, 

and B bands/channels. 

 

Figure 11: Cursor values 

Exercise 4: Creating a mask: This procedure outlines steps to build and apply a mask 

which eliminates pixel values of  0 from QUAC processing: 

 In the Search field of the Toolbox, type QUAC. Double-click the QUAC tool 

which appears in the search results 

 In the QUAC Input File dialog, select the first filename in the list i.e. the OLI 

multispectral dataset, locate the number 7 in the Dims field, which denotes the 

OLI dataset with 7 channels. 
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Figure 12: OLI dataset with 7 channels 

 In the QUAC Input File dialog, click the Mask Options drop-down list and 

select Build Mask. 

 In the Mask Definition dialog, click the Options drop-down list and select 

Import Data Range. 

 Select the same OLI multispectral dataset as in bullet 2, then  click OK. 

 In the Input for Data Range Mask dialog, enter a value of 0 in both the Data 

MaxValue fields. 

 Select the option to Mask pixel if ANY band matches range 

 

 

Figure 13: Mask Parameters 

 Click OK in the Input for Data Range Mask dialog 

 In the Mask definition dialog, click the Options drop-down list and choose 

selected areas off. This will assign a value of 0 to the masked pixels, meaning 

that those areas of the Landsat image will be ignored after applying the mask. 
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 In the Mask Definition dialog, enter an output filename if you want to save the 

mask to disk. Otherwise select the Memory option. 

 Click OK in the Mask Definition dialog. When processing is complete, the mask 

appears in the image window and the Layer Manager. 

 Mask should be listed next to the Select Mask Band button in the QUAC Input 

File dialog. If not, then Select Mask Band and choose the mask that you 

created. 

 Click OK in the QUAC Input File dialog. 

Setting QUAC Parameters: 

 In the QUAC parameters dialog, you can leave the Sensor Type option as 

Unknown. ENVI already has the wavelength information needed to perform 

the atmospheric correction. 

 Enter a filename for the QUAC output file, then click OK. When processing is 

complete, the resulting image appears in the image window and Layer 

Manager. QUAC creates a surface reflectance image, scaled into 2-byte integers 

using a reflectance scale factor of 10,000. So if you divide the current pixel 

values by 10,000, you will have the surface reflectance values, scaled from 0 to 1. 

In the example below, the surface reflectance values over a bright region are: 

 

 Red:0.0893 (8.93%) 

 Green: 0.0653 (6.53%) 

 Blue:0.0818 (8.18%) 

 

Figure 14: Surface Reflectance Values 
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4.0 ACCESSING, LOADING, DISPLAYING, STACKING AND 

RESIZING DATA IN ENVI 4.7 

4.1 Exercise 5: Starting the software 
Envi can be started using desktop shortcut icons or through program files and Envi 4.7 

folder where Envi+IDL or Envi stand alone can be started by a single mouse click as shown 

below: 

 

Figure 15: Launching  Envi 4.7 through program files Menu 

4.2 Exercise 6: Setting Default Data Directory 
After starting Envi 4.7 default data directories can be configured using the preferences 

option in file menu. System preferences dialogue box appears and  default directories can be 

defined. (Set your input default directory to D:\ TRAINING DATA-LANDSAT 8 and 

output directory to D:\ TRAINING DATA-LANDSAT 8\Outputs) 
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Figure 16: Defined default data directory 

4.3 Exercise 7: Adding and Displaying Image 
Add Landsat image single bands to the program as shown in Figure 3. The available band 

list window displays the loaded images  Figure 4. 

 

Figure 17: Adding Landsat image (GeoTiFF format) to Envi 
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Figure 18: Available list of bands loaded 

4.4  Exercise 8: The Display Group  
Three windows appear concurrently: zoom, scroll and image window displays.This 

facilitates interactive visualization. The zoom display window magnifies a selected area with 

a certain magnifying factor. Scroll window allows interactive movement/panning within 

the image scene to select an area of interest. Finally, the image window displays a certain 

portion of the entire scene but not in great detail. 

 

Zoom window 

Scroll window 

Image window 
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Figure 19: Interactive display window in Envi Classic showing false color composite 

4.5 Exercise 9: Developing Image Composites 
For maximum feature/object/class selection, composite images are utilized. These images 

are bands of the same scene acquired using different portions of the Electromagnetic 

Spectrum. Such images bear different information of that feature extraction. Therefore, 

Landsat bands should be stacked together to enable display in either natural colour 

combination (Blue, Green, Red) or false colour composites. 

4.6 Exercise 10: Image Layer/Band Stacking 

Layer stacking combines several bands and makes it possible to display images in different 

colour composite depending on aim of the project undertaken. In this practical guide we will 

use false colour combination: 5, 4, 3 (Near infrared, Red and Green bands) for Landsat 8 OLI 

(Operational Land Imager) and 4, 3, 2 combination for Landsat 7 EMT+ (Enhanced Thematic 

Mapper Plus). 

 

Figure 20: Displayed below are some common band combinations in various Landsat 

Imageries (“LANDSAT 8 (L8) DATA USERS HANDBOOK Version 1.0 June 2015,” 2015). 

False color combination (5, 4, 3): This is the standard "false colour" composite. Vegetation 

appears in shades of red, urban areas are cyan blue, and soils vary from dark to light 

browns. Ice, snow and clouds are white or light cyan. Coniferous trees will appear darker 

red than hardwoods. This is a very popular band combination and is useful for vegetation 

studies, monitoring drainage and soil patterns and various stages of crop growth. Generally, 

deep red hues indicate broad leaf and/or healthier vegetation while lighter reds signify 
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grasslands or sparsely vegetated areas. Densely populated urban areas are shown in light 

blue. Mangroves would appear in deep red hues just along the coastal strip hence is easy to 

discern and discriminate. 

Layer stacking in Envi 4.7: From Envi 4.7 Menu bar go to:Basic Tools > Layer Stacking 

Dialogue box in  Figure 21 appears. Click the tab Import File in order to choose bands to 

stack. A layer Stacking input menu  Figure 22 appears where files from the directory can be 

added via (Open > New File). 

 

Figure 21: Layer stacking 
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Figure 22: Adding an image from the directory 

 

After adding files for stacking, you can re-order them and when satisfied define an output 

directory to obtain the output image.  See Figure 23. After everything is defined, click ok to 

execute the process. 

 

Figure 23: Selected bands for final layers stacking 
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The stacked images can be displayed in 5,4,3 false colour composite by selecting the RGB 

color display and passing band 5 through red filter display, band 4 through green filter and 

band 3 through blue display as shown in Figure 24 below. The resultant image appears as 

shown in Figure 25.  

NOTE: This process can be duplicated for developing other composites. 

 

Figure 24: 5, 4 , 3 color composite 
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Figure 25: False color composite (5, 4, 3) 

4.7 Exercise 11: Image Resizing 

NOTE: For this exercise use data in shapefile data folder. 

According to some previous studies mangroves occur on the coastline and hence is highly 

unlikely to occur further away from the coast (Kirui et al., 2013). Hence this procedure is 

important in reducing the size of the image to about 15 km from both sides of the coastline. 

This ensures that during classification only the features within the boundary (15km buffer) 

are classified. This is done using a predefined vector file of the region of interest (ROI). In 

Envi this process is known as subset: From the Menu bar: 

Basic Tools > Subset Data via ROIs: First the vector file (shapefile) should be loaded into 

Envi and converted to ROIs as follows. From the Menu bar select: Note: Ensure you select 

.shp extension as you browse to the folder location. After opening the vector file the 

following dialogue box appears  

Vector > Open Vector File 
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Confirm the parameters in the first dialogue box and click ok then the second dialogue box 

appears Figure 26 below. 

 

Figure 26:First dialog box 

 

Figure 27: Second context box 
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From second context  Figure 27 export the shapefile to Envi ROI file as follows: File > Export 

Layers to ROI 

 

Figure 28: Selecting an image to use as a base for exporting shapefile to ROI 

Once the image is selected another dialogue box appears with an option to convert all 

records to one ROI or convert each record to new ROI files see Figure 29. Select the first 

option and click ok. 

 

Figure 29: ROI conversion methods 

In order to view the converted ROIs go to the image viewer and: Tools > Region of Interest > 

ROI Tool.  A window will appear showing the ROI. 

From this point we are ready to clip the image using: Basic Tools > Subset Data Via ROIs 
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Figure 30: Selecting the image to subset 

 

Figure 31: Accepting masking of pixels 

 Select the image to subset  Figure 30 and select the ROI to use, accept masking of pixels 

outside of the ROI and select a background value Figure 31. NB: Once the process is 

executed load the clipped/resized image from the available band list. 

 

Figure 32: Resized image 
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5.0 VISUAL IMAGE INTERPRETATION 

Image interpretation is the act of examining images with a goal of identifying objects and 

judging their significance.This is process is very important in training site selection which is 

a critical step in image classification. Training sites are areas in the image that are known to 

be representative of a particular land cover type – for each land cover type of interest.   

Elements of image interpretation aid in identifying the sites during the process of training 

site selection, they include: Tone/colour, texture, size, height, shadow, shape, pattern and 

site and association. Such classes in image interpretation act as training sites (spectral 

examples of classes). Landsat band combinations can be used to enhance the extraction of 

classes or features from the images. The following combinations are among several used for 

different applications. 

NOTE: Band combination vary from intended application and sensor types. Combinations 

presented below applies to Landsat 8 OLI. 

5.1 Exercise 12: Landsat True-Color Composite (RGB: 4, 3, 2)  
True-color composite images approximate the range of vision for the human eye, and hence 

these images appear to be close to what we would expect to see in a normal image or photo.  

For instance, healthy vegetation appears as green, recently cleared fields are very light, 

unhealthy vegetation is brown and yellow, roads are gray and shorelines are white. This 

band combination provides the most water penetration and superior sediment and 

bathymetric information.  True-color images tend to be low in contrast and somewhat hazy 

in appearance. This is because blue light is more susceptible than other bandwidths to 

scattering by the atmosphere. Broad-based analysis of underwater features and land-cover 

are representative applications for true-color composites.  

5.2 Exercise 13: Near Infrared Composite (RGB: 5, 4, 3) 
Adding a near infrared (NIR) band and dropping the visible blue band creates a near 

infrared composite image. This is standard “false colour” composite. Vegetation appears in 

shades of red, urban areas are cyan blue and soils vary from dark to light browns. Ice, snow 

and clouds are white or light cyan.Vegetation in the NIR band is highly reflective due to 

chlorophyll, and a NIR composite vividly shows vegetation in various shades of red.  Water 

appears dark, almost black, due to the absorption of energy in the visible red and NIR 

bands.  
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Table 1: Samples of Training Areas using Landsat 8 false colour composites 

1) Very dense 

  

5 4 3 RGB 

 

2) Dense  

  

5 4 3 RGB 

3) Moderately Dense 

 

5 4 3 RGB 

4) Sparse forest/Grassland 

  

5 4 3 RGB 

5) Water/Suspended        

  

5 4 3 RGB 

6) Water at deep sea 

  

5 4 3 RGB 
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7) Urban/Bare 

         

  

5 4 3 RGB 

8) Clouds and shadows 

 

       

5 4 3 RGB 

      

 

6.0 IMAGE ENHANCEMENT 

During the image interpretation some images may have poor contrast. Such images may 

limit or slow the process of visual image interpretation. In such cases image enhancement 

can be used. 

6.1 Exercise 14: Enhancing the Image 
Enhance Menu tools in image window > Enhance. Figure 34 can be used to perform quick 

contrast stretches, to perform interactive contrast stretching using histograms and to apply 

quick filter enhancements to displayed data. These enhancements are not applied to the data 

files. Any of the enhancement options can be used and the changes are reflected in the image 

immediately. 
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Figure 33: Image enhancement methods 

7.0 CREATING TRAINING SITES 

NOTE: For this exercice, six (6) class types will used i.e Mangroves, Non-mangroves, Water, 

Bare/Urban, Clouds and Shadows. 

Areas in the image that are known to be representative of a particular land cover type 

should be digitized. Sample training areas are then used as spectral signatures during 

classification. After loading the image to be classified, training areas are created as follows: 

From the image window go to: 

7.1 Exercise 15: Accessing the ROI Tool 
Tools > Region of Interest > ROI Tool The ROI Tool when opened allows sites of 

representative classes to be added and later used for classification as follows; 

 To add new ROI use the New Region button  

 In order to rename the created ROI double click it and a cursor appears giving you 

the chance to rename the file. 
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Figure 34: ROI tool used for collecting training sites.  

Training areas can be digitized from the image, scroll or zoom display windows; currently 

the image display window is selected.  

ROI Types: Points, polyline, polygon, rectangle or ellipse can be used to extract the sites 

i.e. go to ROI Type to select these options Figure 35. 

 

 

Figure 35: ROI types used for extracting training sites 



27 
 

 

Figure 36: Selected training sites 

Deleting ROIs: In the process of creating the ROIs in the ROI tool, wrongly added polygons 

can be deleted by going to the area (using Go to button in the ROI tool) then using the active 

display in the ROI Tool (in this case zoom) position the cursor on top of the site and press 

down the scroll button of the Mouse. 

  

8.0 IMAGE CLASSIFICATION 

Digital image classification uses the spectral information represented by the digital numbers 

in one or more spectral bands, and attempts to classify each individual pixel based on this 

spectral information. There two approaches in classification (supervised and unsupervised). 

For the purpose of this short training, we shall use a supervised classification technique 

known as the Maximum likelihood probabilistic method.  

Exercise 16: Maximum likelihood classification (MLC) 
 Maximum likelihood classification (MLC) can be executed from the standard 

menu: 
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Figure 37: MLC (Maximum Classification Classifier) 

 On accessing the maximum likelihood tab a dialogue box appears giving an 

option to select the input image. After selecting the input image and number 

of bands to be used (using Spectral Subset) a window appears which enables 

the Training areas created using the ROI Tool to be selected see Figure 40 

below. 
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Figure 38: Selecting an input for MLC 

 

Figure 39: Selecting training areas to be used as spectral signatures 
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Figure 40: Sample of a classified image 

9.0 POST- CLASSIFICATION SMOOTHING 

Exercise 17: Postclassification through majority/minority analysis 
After applying MLC, smoothing should be done on the classified images in order to 

eliminate the effect of salt and pepper that is common with pixel based methods. In Envi 4.7 

this is done through minority/majority analysis to remove such effects (salt and paper). The 

following procedure is applied: Classification > Postclassification > Majority/Minority Analysis. 
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Figure 41: Filtered Image 

10.0 GROUND - TRUTH DATA COLLECTION 

Verification is a key phase in terms of the generation of data and information products from 

remotely sensed data. Accuracy assessment allows one to both determine whether the data 

achieves a predetermined minimum acceptable level of accuracy and to determine the 

uncertainty in the data produced. At each location, based on the Landsat 7 & 8 mangrove 

cover derived maps, randomly selected mangrove sites were surveyed. Randomly generated 

non‐mangrove sites were also surveyed. Due to the scale of the imagery used in creating the 

cover map (30m x 30m pixels), the surveys had to incorporate sufficient distance between 

data points at each site.This was in accordance with the methodology proposed by ICFI 

(2009). There were no local maps with known accuracy or sufficient field data available to 

assess relative accuracy. Hence, we based our estimation of classification accuracy on 

independent and systematic method for selecting validation points. We used random points 

separated by 200 metres within random sampling blocks. Due to time and logistical 

limitations, we assessed the areas we did not collect validation points from by visual 

interpretation of high-resolution images (Digital Globe) in Google Earth software. We only 

used the areas identified as mangroves on the landcover map or in Google Earth. In total, 

some 258 survey points were collected across the sampling blocks visited. Surveys were 

conducted at the randomly selected mangrove sites, using the GPS coordinates.  

11.0 ACCURACY ASSESSMENT PROCEDURES 

The random sample validation points from field will be used for accuracy assessment using 

the error matrix/confusion matrix. The confusion matrix shows the proportion of correctly 
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classified and misclassified pixels in a matrix and therefore several accuracy measures can 

be derived from it. 

11.1 Exercise 18: Performing accuracy test 

 Open Classified classified image, i.e. go to File > Open Image File then browse to 

output Folder inside TRAINING DATA_LANDSAT8 folder Figure 43. 

 Open vector in Accuracy Test Folder (contains all shapefile of categories sampled 

and observed in the field) Figures 44. Locate by: Vector > Open Vector File. Then 

export the layers to ROI (Convert each record of an EVF to a new ROI) using the loaded 

classified as base Figures 43. 

 

 

Figure 42: Base Image 
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Figure 43: Accessing the class category layers 

 Export the layers you opened into ROI and convert them into one record using the 

option (Convert all records of an evf to one ROI) see Figure 45. 

 

Figure 44: Using a base image to Convert all records of an evf to one ROI for use in accuracy 

assessment 

 Confirming the converted layers  > Open the ROI tool to view the converted layer 

Figure 46. 
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Figure 45: The converted shapefiles to ROIs 

 Click > Classification > Postclassification > Confusion Matrix > Using Ground Truth ROIs. 

To start the accuracy assessment tool using ground truth ROIs see Figure 47 and 

select the land-cover as a base image. 
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Figure 46: Performing accuracy assessment tool using ground truth ROIs 

 A dialogue box will appear allowing you to match the classes in the image with 

ground truth points. Select corresponding combinations then click on Add 

Combination. In this case the there are only three layers to match with i.e. Mangroves 

corresponds with mangroves, Non-mangroves corresponds to Non-mangroves and 

Urban corresponds with Bare/Urban Figure 48. 

 

Figure 47: Equating ground truth data with classified image 

 Finish the process of matching the classes and ground truth data by accepting the 

parameters in the dialogue box that pops up below to generate the report Figure 49. 
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Figure 48: The parameters sets for generating accuracy report 

 Confusion matrix is generated automatically by the software, containing class 

accuracy and overall accuracy Figure  

 

Figure 49: Confusion/Error Matrix 

11.2 Interpretating the Error/Confusion Matrix 

Accuracy of each class was expressed as a matrix showing errors of commission and 

omission. This was derived from the field data points and extracted points from the 

classification map. Overall classification accuracy and Kappa coefficient was computed i.e 

72.97 and 0.45 respectively. Overall map accuracy was computed by dividing the total 
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number of correctly classified pixels by the total number of reference pixels in the error 

matrix. Overall accuracy uses only the main diagonal elements of the error matrix. The 

accuracy of individual categories is computed by dividing the corresponding row or the 

corresponding column. When the number of correct pixels in a category is divided by the 

total number pixels in the corresponding row (i.e. the total number pixels that were 

classified in that category), the result is an accuracy measure called “user’s accuracy” and is 

a measure of commission error. “User’s accuracy”, or reliability, is indicative of the 

probability that a pixel classified on the map actually represent that category on the ground. 

On the other hand, when the correct number of pixels in a category is divided by the total 

number of pixels in the corresponding column (i.e. the total number of pixels for that 

category in the reference data) the result is called “producer’s accuracy”. Producer’s 

accuracy indicates the probability of reference pixels being correctly classified and is really a 

measure of omission error. For this particular training both the overall accuracy is lower 

than the limits of U.S. Geological Survey's suggested threshold of 85%. Though, the overall 

accuracy wholly depends on how the accuracy assessment regions of intrest are selected for 

a particular region.  

12.0 SUMMARY 

This training manual and products were developed using LandSat 8 OLI data, a supervised 

classification method was used. It involves the creation of training sites and then the use 

maximum likelihood classification method to develop the land cover products.Post 

classification procedures such as filtering, pixel/cell editing are used to refine the 

classification of the final products. Accuracy assessment was conducted using randomly 

generated actual field data and point interpretation from LandSat imagery. Used indices for 

assessing the map accuracy were the Overall accuracy and the Kappa coefficient. At the end 

of the training, the participants are expected to have acquired skills in image acquisition, 

exploration, analysis, visualization, enhancenment, classification and interpretation. Besides, 

the students will have gained skills in GIS, the generation of indices for assessing map 

accuracy, and interpretation of such indices. 
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